Bitcore installation build error

I have been trying to install bitcore globally for npm and it fails EVERY. SINGLE. TIME. I am installing on centos 6 server. Everything has been updated to support bitcore. I have installed:

node 4.2.3
python2.7.10
gcc 5.3.0

I have posted before and the post was just ignored or maybe no one had anything to say. I have found other posts related to this problem but none of the proposed solutions worked for me. Is there a solution to this problem? Have any of the core developers even looked into it?