Bitcore installation failing, Permission denied, could not read from repository

I am following the instructions on the the website for installing a full node. this is the error i am getting.

npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.
npm ERR! git submodule -q update --init --recursive: No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR! git submodule -q update --init --recursive:
npm ERR! git submodule -q update --init --recursive: No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR! git submodule -q update --init --recursive:
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: Cloning into bare repository ‘/home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8’…
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: Warning: Permanently added the RSA host key for IP address ‘192.30.252.128’ to the list of known hosts.
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: Permission denied (publickey).
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: fatal: Could not read from remote repository.
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8:
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: Please make sure you have the correct access rights
npm ERR! git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8: and the repository exists.
npm ERR! Linux 3.13.0-86-generic
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “-g” "bitcore"
npm ERR! node v5.10.0
npm ERR! npm v3.8.5
npm ERR! code 128

npm ERR! Command failed: git clone --template=/home/kreshendo/.npm/_git-remotes/_templates --mirror git@github.com:bitpay/engine.io-client.git /home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8
npm ERR! Cloning into bare repository ‘/home/kreshendo/.npm/_git-remotes/git-github-com-bitpay-engine-io-client-git-bitpay-1-5-4-534e88e8’…
npm ERR! Warning: Permanently added the RSA host key for IP address ‘192.30.252.128’ to the list of known hosts.
npm ERR! Permission denied (publickey).
npm ERR! fatal: Could not read from remote repository.
npm ERR!
npm ERR! Please make sure you have the correct access rights
npm ERR! and the repository exists.
npm ERR!
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /home/kreshendo/npm-debug.log

how do i fix this?

I didn’t think it was necessary (as git with https should be used), but you may need to add your publickey to github.

Done. I’m trying the installation again now.

ok now I have this error.

npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.
npm ERR! git submodule -q update --init --recursive: No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR! git submodule -q update --init --recursive:
npm ERR! git submodule -q update --init --recursive: No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR! git submodule -q update --init --recursive:
npm ERR! git submodule -q update --init --recursive: No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR! git submodule -q update --init --recursive:
npm ERR! Linux 3.13.0-86-generic
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “-g” "bitcore"
npm ERR! node v5.10.0
npm ERR! npm v3.8.5
npm ERR! code 1

npm ERR! Command failed: git submodule -q update --init --recursive
npm ERR! No submodule mapping found in .gitmodules for path 'support/web-socket-js’
npm ERR!
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /home/kreshendo/npm-debug.log

Node.js 4 is supported (Node.js 5 is untested and may require some manual work)

oh ok. im installing nvm now. Does it have to be a specific version?

Latest version of 4 should be okay (v4.4)

thanks a lot. looks like its working now. I was wondering if there is a way to delete a node. Like after I’m done using a testnet node, how do I delete it? I’m just trying to save space on my disk drive.

Testnet is actually quite small in comparison with livenet, so it may not be worth removing.

The data is stored in the location specified in “datadir” in your “bitcore-node.json” configuration. The testnet data is in the testnet3 sub directory.