BWC clients < 1.2 are no longer supported


#1

Hi,

I tried to install full copay stack and am at a loss with the last step. I have the latest version of bitcore-wallet-service and bitcore-wallet-client working fine, but bitcore-wallet does not want to work with me:

$ npm list --depth=0
/home/copay/copay
├── bitcore-wallet@0.6.1
├── bitcore-wallet-client@3.0.0
└── bitcore-wallet-service@1.10.0

$ node wallet create “test” 2-2
[info] Generating new keys
[error] <ClientError:UPGRADE_NEEDED BWC clients < 1.2 are no longer supported.>
ClientError {
code: ‘UPGRADE_NEEDED’,
message: ‘BWC clients < 1.2 are no longer supported.’ }

I tried this on two machines, with same result. Clearly BWC version is 3.0.0, yet BW is arguing otherwise.

Can anyone give any pointers?


#2

Ok so BWC is already sub-included in ‘bitcore-wallet’.

I edited “bitcore-wallet” packages.json and changed BWC version from “0.6.4” to “^1.2.0” and ran “npm update” and it seems the problem is gone.

Apparently there is a versioning issue…?


(FedFranz) #3

Same problem here. And no success with the workaround described by qaqo.

Can anybody help solve this issue?


(FedFranz) #4

Solved by removing and reinstalling ‘bitcore-wallet’ (git version).
Here the detailed steps: https://github.com/bitpay/bitcore-wallet-client/issues/329