Don't know what I did but need to recreate


#1

using ubuntu 16.04.1 I was finally able to get bitcore to work. Before I had errors saying need to install with root access even though I never entered sudo.
Using a fresh install of ubuntu I can only think of 2 things

  1. some restart I did after installing npm
    2 I think I updated npm to the latest that might have worked.

Now onto another test before I fully implement this on dedicated server

Any help as to why I had such a hard time? I followed the guides including installing v4 nmp


#2

tried to install it again with no luck, still don’t know what I did
ubuntu 16.04.01 64 bit
fresh install
sudo apt install curl
curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs
switched to a non admin user
npm install -g bitcore-node@latest
then the permission issues


#3

been about a week since I tried it still nothing
install curl
install git
curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs
npm isntall -g npm@latest
apt update
apt-get install libzmq3-dev build-essential
apt update
bitcore user
npm install bitcore-build
npm install -g bitcore-node@latest


#4

I finally got it and think I know were I went wrong
npm -g isntall npm@latest.
I never realized that npm v4 is needed and I was trying to run the latest npm.
npm use v4 or something like that

On a side note ubuntu 16.10 has a dependency install isue
apt-get install libzmq3-dev build-essential
won’t work, there is a way to obtain this but I just downgraded to 16.04 lts and worked.