Error settig up bitcore on Mac

(Marijan) #1

I am using node v4.6.2, and nvm 0.33.4. Here is the error I get when i start bitcored on terminal:

Error: More than one instance of bitcore-lib found. Please make sure to require bitcore-lib and check that submodules do not also include their own bitcore-lib dependency.
at Object.bitcore.versionGuard (/root/bitcore/node_modules/bitcore-wallet-service/node_modules/bitcore-lib/index.js:16:11)
at Object. (/root/bitcore/node_modules/bitcore-wallet-service/node_modules/bitcore-lib/index.js:20:9)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object. (/root/bitcore/node_modules/bitcore-wallet-service/bitcorenode/index.js:10:15)
at Module._compile (module.js:409:26)

(Amit Singhai) #2

Same problem for me too but with different modules , I tried cleaning up duplicates but it’s keep popping up
My node version is 6.x