Help needed on setting up please

I’m trying to get bitcore running on a fresh Ubuntu 16.04 Intel PC with 8Gb RAM.
I followed the steps to create a user called “bitcore” and swap to the user with “sudo su - bitcore” as recommended.

I had to modify the data directory to be on an external drive so modified the “bitcore-node.json” file so that the bitcoind/spawn/datadir points to

"/media/myusbdrive/blockchaindata/bitcoin/blockchain/data_livenet"

I run this and everything synced 100% after 7 days of running.
I next accidentally unplugged the USB drive, quickly plugged it back in but alias I think a file was open for writing as it happened and the client refused to run again. I tried a lot to get it running but in the end gave up, deleted it all and started again.

7 days later, back up and running with 100% synced and insight viewable in the browser.

I next pressed Ctrl C + Ctrl X to exit the terminal and I took a copy of the data directory just incase it gets corrupted again. I went to run “bitcore” again but it wouldn’t restart. Restarted the machine and again same error.(This is the same error as when the USB was unplugged too so starting to think the file wasn’t corrupted)

It fails after doing lots of
warn:Verifying blocks…
warn:Verifying blocks…
warn:Verifying blocks…
warn:Verifying blocks…
error: Failed to start services
error: RPCError: Verifying blocks…
at Bitcoin_wrapRPCError (…)
bitcoind.js:767:28.

Any idea how I can get this running again and/or get any information on what is causing it to fail?
Is pressing Ctrl C+Ctrl X ok to do when bitcored has been running? If not how do others exit it?

I’m going crazy trying to get this to work, any help would be really appreciated.
Thanks,

I would take a look at the debug log for bitcoin at /path/to/bitcoin-datadir/debug.log.