How to properly configure the Node and the Wallet Service? HELP

(Conejoninja) #1

Hi, I’m having some trouble finding documentation to properly configure the wallet service and the bitcore node itself.

I’m running the node inside a docker container behind a proxy. I properly configure the node to use https (as well as the proxy) and it runs smoothly, but when I added the wallet-service, I got the following error (insight-api / insight-ui still works)

ERR! Error connecting to Insight (livenet) @ https://localhost:3001 

If I disbale https on the bitcore-node.json configuration, then it works (as it tries to connect to http://localhost instead. I can’t find where to change the url and instead of using localhost, using the domain of the node. Once “it’s working” (as it doesn’t output any error)… the URL simply doesn’t work

http://example.com:3232/bws/api returns “Cannot GET /bws/api”

Also, I’m not able to find where to change the URL of insight, as of now, it’s https ://example.com:3001/insight/ and I want to get rid of it (if possible) or at least to change it.

0 Likes

(Braydon Fuller) #2

You can change the URL with these config options:

  "servicesConfig": {
    "insight-ui": {
      "routePrefix": "",
      "apiPrefix": "api"
    },
    "insight-api": {
      "routePrefix": "api",
      "enableCache": true
    }
  }
0 Likes