// , Insight connects, but I keep getting the message, "Waiting for blocks". How do I make sure that Insight can allow block exploration?

(V6) #1

// , Hi, I’m Nathan.

Not sure how interested people are in helping to support Insight, but maybe I could at least get some directions in which to look further.

I have a problem with Insight, that it reports “Waiting for blocks” for a long period of time, without actually showing any blocks, even after a partial sync of bitcored.

Perhaps I need a full bitcored sync?

Anyway, I have the following bitcored logs:

~/explorer$ bitcored [2016-04-30T03:14:04.155Z] info: Starting bitcoind [2016-04-30T03:16:49.403Z] info: Bitcoin Daemon Ready [2016-04-30T03:16:49.405Z] info: Starting db [2016-04-30T03:17:13.142Z] info: Bitcoin Height: 333301 Percentage: 44.16251754760742 [2016-04-30T03:17:25.144Z] info: Bitcoin Height: 333302 Percentage: 44.162715911865234 [2016-04-30T03:17:39.708Z] info: Bitcoin Height: 333303 Percentage: 44.163021087646484 [2016-04-30T03:18:17.869Z] info: Bitcoin Height: 333304 Percentage: 44.1632080078125 [2016-04-30T03:18:19.229Z] info: Bitcoin Database Ready [2016-04-30T03:18:19.231Z] info: Starting address [2016-04-30T03:18:21.196Z] info: Bitcoin Height: 333305 Percentage: 44.16336441040039 [2016-04-30T03:18:53.199Z] info: Bitcoin Height: 333306 Percentage: 44.163780212402344 [2016-04-30T03:18:57.200Z] info: Bitcoin Height: 333307 Percentage: 44.16391372680664 [2016-04-30T03:18:57.523Z] info: Starting web [2016-04-30T03:19:24.889Z] info: Starting insight-api [2016-04-30T03:19:24.980Z] info: Bitcoin Height: 333308 Percentage: 44.16435241699219 [2016-04-30T03:19:24.981Z] info: Starting insight-ui [2016-04-30T03:19:25.797Z] info: Bitcore Node ready [2016-04-30T03:19:49.918Z] info: Bitcoin Height: 333309 Percentage: 44.16458511352539 [2016-04-30T03:27:42.827Z] info: Bitcoin Height: 333310 Percentage: 44.18981170654297 [2016-04-30T03:27:45.226Z] info: Bitcoin Height: 333334 Percentage: 44.190059661865234 [2016-04-30T03:27:52.810Z] info: Database Sync Status: Tip: 00000000000000000a3ad24280ea89b4fbfe9b05e3d63b30f97d3465b2f56418 Height: 313239 Rate: 0.2 blocks per second [2016-04-30T03:27:57.902Z] info: Bitcoin Height: 333335 Percentage: 44.191898345947266 [2016-04-30T03:28:02.815Z] info: Database Sync Status: Tip: 00000000000000002edf063dbb387b87919f0b1736bf7b86f398087f3d547dd5 Height: 313243 Rate: 0.4 blocks per second [2016-04-30T03:28:13.104Z] info: Database Sync Status: Tip: 00000000000000001aa334561f883d3765a76d9b5b160f216c607d249d0408f2 Height: 313244 Rate: 0.1 blocks per second [2016-04-30T03:28:13.105Z] info: Bitcoin Height: 333336 Percentage: 44.19346618652344 [2016-04-30T03:28:23.113Z] info: Database Sync Status: Tip: 00000000000000000a7d9eca2fe54de6433cd75dcf84fed9db6105f1c8f31a52 Height: 313248 Rate: 0.4 blocks per second [2016-04-30T03:28:25.523Z] info: Bitcoin Height: 333337 Percentage: 44.193580627441406 [2016-04-30T03:28:33.115Z] info: Database Sync Status: Tip: 00000000000000000a8d01ad5adccbf561e1354673c308f3b0b3af762b613882 Height: 313252 Rate: 0.4 blocks per second

I have tried killing bitcored, and starting it again with the same configuration.

When I kill bitcored, Insight, of course, does not connect. When I restart bitcored, I see this whole “Waiting for blocks” bullshit.

See, the above all looks very nice, but I seem to get no joy in Insight: http://imgur.com/NpQRtLv

Anyway, I wonder what I can do to troubleshoot this further?

I’ve checked the memory requirements, but those don’t seem to be a problem. 4GB RAM and 500GB disk are available for this little guy, along with a few processors.

Maybe I need to make a fresh VPS and try again, there?

Even if a fresh VPS is the only option, I’d like to know how to troubleshoot this, regardless. Maybe my synchronization with the blockchain is too slow.

P.S. Thanks in advance, if anyone takes the time to read this screed. I also did search the github.com repository for this, with the following result: https://github.com/bitpay/insight-ui/blob/master/po/es.po

0 Likes