Installation failed. prebuild error?!?!

(Kreshendo) #1

Hi guys.

I’m having a problem installing bitcore on my centos server. when I type “npm install -g bitcore” the installation fails and I get this error.

prebuild ERR! build error
prebuild ERR! stack Error: make failed with exit code: 2
prebuild ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/bitcore/node_modules/node-gyp/lib/build.js:276:23)
prebuild ERR! stack at emitTwo (events.js:87:13)
prebuild ERR! stack at ChildProcess.emit (events.js:172:7)
prebuild ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
prebuild ERR! not ok
prebuild ERR! build Error: make failed with exit code: 2
prebuild ERR! build at ChildProcess.onExit (/usr/local/lib/node_modules/bitcore/node_modules/node-gyp/lib/build.js:276:23)
prebuild ERR! build at emitTwo (events.js:87:13)
prebuild ERR! build at ChildProcess.emit (events.js:172:7)
prebuild ERR! build at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
/usr/local/lib
└── (empty)

npm ERR! Linux 2.6.32-573.8.1.el6.x86_64
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” “-g” "bitcore"
npm ERR! node v4.2.2
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE

npm ERR! leveldown@1.4.3 install: prebuild --download
npm ERR! Exit status 2
npm ERR!
npm ERR! Failed at the leveldown@1.4.3 install script ‘prebuild --download’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the leveldown package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! prebuild --download
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs leveldown
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls leveldown
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /root/npm-debug.log
npm ERR! code 1

i have seen other people with similar problems but I haven’t seen a solution that can help me.

(Kreshendo) #2

bump. please someonetell me something about this. i need help. nothing i have tried has worked to fix this problem.