Keep getting 429 code


#1

I thought I disabled the api, I did a test of some random address but after some time get a 429 error
I am unsure if the api limit kicks in or the system can’t keep up.
API kicks in just over 10000 api requests, both local and over the web

There is a post recently that I copied and pasted the disable api limit. .

{
“network”: “livenet”,
“port”: 3001,
“services”: [
“bitcoind”,
“web”,
“insight-api”,
“insight-ui”
],
“servicesConfig”: {
“insight-api”: {
“disableRatelimiter”: “true”
},
“bitcoind”: {
“spawn”: {
“datadir”:
"./data",
“exec”: “/home/bitcoin/.nvm/versions/node/v4.6.1/lib/node_modules/bitcore-node/bin/bitcoind”
}
}
}
}

I can run it on the node pc or on a pc on the local network.


#2

figured it out
in the api folder there is a file. In it there are hard aoi request limits (ratelimiter.js)
10800 is the normal for disabled api
By changing the
normal: {
totalRequests: options.limit || 3 * 60 * 60, // 10,800
interval: options.interval || THREE_HOURS

to something like

normal: {
totalRequests: options.limit || 3 * 60 * 60 * 1000000, // 10,800,000,000
interval: options.interval || THREE_HOURS

it can handle more. Still limited but works so far.
Doing tests with multiple connections and working so far