Npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!


(Aasheikh) #1

I have checkout bitcore-wallet-client from github (npm isntall is the same issue as well), and getting the following error

$ npm install
npm WARN package.json bitcore-wallet-client@0.0.36 No license field.
npm ERR! Linux 3.13.0-53-generic
npm ERR! argv “/home/asheikh/installed/node-v0.12.4-linux-x64/bin/node” “/home/asheikh/installed/node-v0.12.4-linux-x64/bin/npm” "install"
npm ERR! node v0.12.4
npm ERR! npm v2.10.1
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package grunt does not satisfy its siblings’ peerDependencies requirements!
npm ERR! peerinvalid Peer grunt-contrib-concat@0.3.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-uglify@0.2.4 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-css-url-replace@0.2.5 wants grunt@~0.4.5
npm ERR! peerinvalid Peer grunt-contrib-cssmin@0.6.1 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-copy@0.5.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-clean@0.5.0 wants grunt@~0.4.0


(Aasheikh) #2

I guess no body know what the issue is or it is only me :smile: