Test the Wallet Service using Copay


(Responsive) #1

Using the Bitcore wallet service tutorial.

Trying to test it on http://localhost:3232/bws/api
instead of your-bitcore-node

I get this error “Cannot GET /bws/api”.

What is the thing I am doing wrong? I am sure it is very basic.

When I run bitcored in the terminal of the direct I want to test the wallet. “wallet”

[2016-11-09T17:48:08.753Z] info: Using config: /home/responsive/Sandbox/Bitcoin/wallet/mynode/bitcore-node.json
[2016-11-09T17:48:08.757Z] info: Using network: livenet
[2016-11-09T17:48:08.760Z] info: Starting bitcoind
[2016-11-09T17:48:08.767Z] info: Using bitcoin config file: /home/responsive/Sandbox/Bitcoin/wallet/mynode/data/bitcoin.conf
[2016-11-09T17:48:08.776Z] info: Starting bitcoin process
[2016-11-09T17:48:13.861Z] warn: Loading wallet…
[2016-11-09T17:48:18.876Z] warn: Loading wallet…
[2016-11-09T17:48:23.923Z] info: Bitcoin Height: 0 Percentage: 0.00
[2016-11-09T17:48:23.934Z] info: Bitcoin Daemon Ready
[2016-11-09T17:48:23.936Z] info: Starting web
[2016-11-09T17:48:24.085Z] info: Starting insight-api
[2016-11-09T17:48:24.086Z] info: Starting bitcore-wallet-service
info Using message broker server at localhost:3380
info Using locker server:localhost:3231
ERR! Error connecting to Insight (livenet) @ localhost:3001
Connection established to mongoDB
info Using locker server:localhost:3231
info Using message broker server at localhost:3380
[2016-11-09T17:48:24.562Z] warn: ZMQ connection delay: tcp://127.0.0.1:28332
[2016-11-09T17:48:24.563Z] info: ZMQ connected to: tcp://127.0.0.1:28332
Connection established to mongoDB
info Using message broker server at localhost:3380
[2016-11-09T17:48:24.628Z] info: Bitcore Node ready
info Connected to Insight (livenet) @ localhost:3001
[2016-11-09T17:48:25.685Z] info: ::ffff:127.0.0.1 web socket subscribe: inv
info Connected to Insight (testnet) @ test-insight.bitpay.com:443

Any insite?


(Chris Rico) #2

The BWS API doesn’t expose a GET endpoint. The easiest way to test it is to point a Copay wallet at it.


(Responsive) #3

cool. has anyone done a tutorial on it?


(Chris Rico) #4

Buried in the advanced settings there’s an option to change the BWS endpoint.


(Responsive) #5

where’s the advance settings?

i am following the other tutorial. still the get error.