Unable to install Bitcore - node-gyp rebuild

(jetyap) #1

Hi all, I’m new to bitcore development and I’m really keen to get a node up and running to test the functionalities in bitcore.

Just installed Ubuntu, and followed the guide. As I’m installing bitcore, I’ve had multiple errors pop up. Can someone help please?

npm install -g bitcore

bitcore-node@3.1.3 preinstall /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node
./scripts/download

Downloading bitcoin: https://github.com/bitpay/bitcoin/releases/download/v0.12.1-bitcore-4/bitcoin-0.12.1-linux64.tar.gz
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 605 0 605 0 0 448 0 --:–:-- 0:00:01 --:–:-- 448
100 24.6M 100 24.6M 0 0 1246k 0 0:00:20 0:00:20 --:–:-- 1638k
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 591 0 591 0 0 451 0 --:–:-- 0:00:01 --:–:-- 451
100 1154 100 1154 0 0 402 0 0:00:02 0:00:02 --:–:-- 1216
Unpacking bitcoin distribution
bitcoin-0.12.1/
bitcoin-0.12.1/bin/
bitcoin-0.12.1/bin/bitcoin-cli
bitcoin-0.12.1/bin/bitcoind
bitcoin-0.12.1/bin/bitcoin-qt
bitcoin-0.12.1/bin/bitcoin-tx
bitcoin-0.12.1/bin/test_bitcoin
bitcoin-0.12.1/bin/wallet-utility
bitcoin-0.12.1/include/
bitcoin-0.12.1/include/bitcoinconsensus.h
bitcoin-0.12.1/lib/
bitcoin-0.12.1/lib/libbitcoinconsensus.so
bitcoin-0.12.1/lib/libbitcoinconsensus.so.0
bitcoin-0.12.1/lib/libbitcoinconsensus.so.0.0.0

utf-8-validate@1.2.2 install /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/utf-8-validate
node-gyp rebuild

gyp WARN download NVM_NODEJS_ORG_MIRROR is deprecated and will be removed in node-gyp v4, please use NODEJS_ORG_MIRROR
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:449:14)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:353:11
gyp ERR! stack at F (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:69:16)
gyp ERR! stack at E (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:82:15)
gyp ERR! System Linux 4.4.0-62-generic
gyp ERR! command “/home/bitcore/.nvm/versions/node/v4.8.2/bin/node” “/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” "rebuild"
gyp ERR! cwd /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/utf-8-validate
gyp ERR! node -v v4.8.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

bufferutil@1.2.1 install /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/bufferutil
node-gyp rebuild

gyp WARN download NVM_NODEJS_ORG_MIRROR is deprecated and will be removed in node-gyp v4, please use NODEJS_ORG_MIRROR
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:449:14)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:353:11
gyp ERR! stack at F (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:69:16)
gyp ERR! stack at E (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:82:15)
gyp ERR! System Linux 4.4.0-62-generic
gyp ERR! command “/home/bitcore/.nvm/versions/node/v4.8.2/bin/node” “/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” "rebuild"
gyp ERR! cwd /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/bufferutil
gyp ERR! node -v v4.8.2
ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN optional dep failed, continuing utf-8-validate@1.2.2
npm WARN optional dep failed, continuing bufferutil@1.2.1

zmq@2.15.3 install /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/zmq
node-gyp rebuild

gyp WARN download NVM_NODEJS_ORG_MIRROR is deprecated and will be removed in node-gyp v4, please use NODEJS_ORG_MIRROR
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:449:14)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:353:11
gyp ERR! stack at F (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:69:16)
gyp ERR! stack at E (/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack at /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:82:15)
gyp ERR! System Linux 4.4.0-62-generic
gyp ERR! command “/home/bitcore/.nvm/versions/node/v4.8.2/bin/node” “/home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” "rebuild"
gyp ERR! cwd /home/bitcore/.nvm/versions/node/v4.8.2/lib/node_modules/bitcore/node_modules/bitcore-node/node_modules/zmq
gyp ERR! node -v v4.8.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm ERR! Linux 4.4.0-62-generic
npm ERR! argv “/home/bitcore/.nvm/versions/node/v4.8.2/bin/node” “/home/bitcore/.nvm/versions/node/v4.8.2/bin/npm” “install” “-g” "bitcore"
npm ERR! node v4.8.2
npm ERR! npm v2.15.11
npm ERR! code ELIFECYCLE

npm ERR! zmq@2.15.3 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zmq@2.15.3 install script ‘node-gyp rebuild’.
npm ERR! This is most likely a problem with the zmq package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs zmq
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR!
npm ERR! npm owner ls zmq
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/bitcore/npm-debug.log

0 Likes

(jetyap) #2

Update: Installed python 2.7 and it resolved the problem.

1 Like