Unable to npm install bitcore

On OSX, I am trying to install bitcore, but it is not working. I get the error below after I run. “npm install bitcore”

Can anyone please help me with this?? Thank you in advance.

Build finished successfully.
make: *** No rule to make target `Release/obj.target/libbitcoind/src/libbitcoind.o', needed by `Release/bitcoind.node'.  Stop.
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/Users/myname/.nvm/versions/node/v5.6.0/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack     at emitTwo (events.js:100:13)
gyp ERR! stack     at ChildProcess.emit (events.js:185:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Darwin 14.5.0
gyp ERR! command "/Users/myname/.nvm/versions/node/v5.6.0/bin/node" "/Users/myname/.nvm/versions/node/v5.6.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "--debug=false" "rebuild"
gyp ERR! cwd /Users/myname/node_modules/bitcore-node
gyp ERR! node -v v5.6.0
gyp ERR! node-gyp -v v3.2.1
gyp ERR! not ok

npm WARN enoent ENOENT: no such file or directory, open '/Users/myname/package.json'
npm WARN myname No description
npm WARN myname No repository field.
npm WARN myname No README data
npm WARN myname No license field.
npm ERR! Darwin 14.5.0
npm ERR! argv "/Users/myname/.nvm/versions/node/v5.6.0/bin/node" "/Users/myname/.nvm/versions/node/v5.6.0/bin/npm" "install" "bitcore"
npm ERR! node v5.6.0
npm ERR! npm  v3.6.0
npm ERR! code ELIFECYCLE

npm ERR! bitcore-node@2.1.0 install: `./bin/install`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bitcore-node@2.1.0 install script './bin/install'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the bitcore-node package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     ./bin/install
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs bitcore-node
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls bitcore-node
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/myname/npm-debug.log

Are you install from npm package manager or local sources?

I don’t have a solution for you, but I was having this issue too and was unable to resolve it. Mine only happened when I tried to install globally from the checked out sources (npm install -g) or with a prefix (npm install --prefix) though, and installing locally worked fine.