ZMQ connection delay and bitcoind shutdown


#1

I got a problem of that bitcoind auto shut down every period of time,I handle it by auto restart bitcoind but there is a sync problem, /api/sync can not get the current blockheight of bitcoind always.please help.


#2

I came across the sync problem. For my problem, I set the env variable INSIGHT_FORCE_RPC_SYNC=1. In my case, I removed the database firstly, and restart the node with the commandline INSIGHT_FORCE_RPC_SYNC=1 ./bitcore-node start.

hope it is helpful


#3

thank you for your help,I will have a try.


#4

Hi mate,

I’ve encounter same problem and I’m new to bitcore. I’ve tried to use INSIGHT_FORCE_RPC_SYNC=1 ./bitcore-node start. but I still get warn: ZMQ connection delay: tcp://127.0.0.1:8332 continually. Could I ask where did the insight-api fetch data from the database? I don’t understand how to remove the database on my local setting. Could you possibly help me on this one?

Thanks in advance~